What’s Vulnerable › Vulnerabilities
CVE-2022-29219: Integer Overflow in Lodestar
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-24 · updated 2026-06-17
- Weakness: CWE-190
Description
Lodestar is a TypeScript implementation of the Ethereum Consensus specification. Prior to version 0.36.0, there is a possible consensus split given maliciously-crafted `AttesterSlashing` or `ProposerSlashing` being included on-chain. Because the developers represent `uint64` values as native javascript `number`s, there is an issue when those variables with large (greater than 2^53) `uint64` values are included on chain. In those cases, Lodestar may view valid_`AttesterSlashing` or `ProposerSlashing` as invalid, due to rounding errors in large `number` values. This causes a consensus split, where Lodestar nodes are forked away from the main network. Similarly, Lodestar may consider invalid `ProposerSlashing` as valid, thus including in proposed blocks that will be considered invalid by the network. Version 0.36.0 contains a fix for this issue. As a workaround, use `BigInt` to represent `Slot` and `Epoch` values in `AttesterSlashing` and `ProposerSlashing` objects. `BigInt` is too slow to be used in all `Slot` and `Epoch` cases, so one may carefully use `BigInt` just where necessary for consensus.
Affected products
- ChainSafe lodestar: before 0.36.0 — fixed in 0.36.0
How to fix
Upgrade to a fixed version: ChainSafe lodestar 0.36.0. Check the vendor advisory for mitigations.
References
- https://github.com/ChainSafe/lodestar/pull/3977
- https://github.com/ChainSafe/lodestar/releases/tag/v0.36.0
- https://github.com/ChainSafe/lodestar/security/advisories/GHSA-cvj7-5f3c-9vg9
- https://github.com/ChainSafe/lodestar/pull/3977
- https://github.com/ChainSafe/lodestar/releases/tag/v0.36.0
- https://github.com/ChainSafe/lodestar/security/advisories/GHSA-cvj7-5f3c-9vg9
Get alerted when CVE-2022-29219 or the next vulnerability affects your stack