What’s Vulnerable › Vulnerabilities
CVE-2022-29222: Improper Certificate Validation in Pion DTLS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-21 · updated 2026-06-17
- Weakness: CWE-295
Description
Pion DTLS is a Go implementation of Datagram Transport Layer Security. Prior to version 2.1.5, a DTLS Client could provide a Certificate that it doesn't posses the private key for and Pion DTLS wouldn't reject it. This issue affects users that are using Client certificates only. The connection itself is still secure. The Certificate provided by clients can't be trusted when using a Pion DTLS server prior to version 2.1.5. Users should upgrade to version 2.1.5 to receive a patch. There are currently no known workarounds.
Affected products
- pion dtls: before 2.1.5 — fixed in 2.1.5
How to fix
Upgrade to a fixed version: pion dtls 2.1.5. Check the vendor advisory for mitigations.
References
- https://github.com/pion/dtls/commit/d2f797183a9f044ce976e6df6f362662ca722412
- https://github.com/pion/dtls/releases/tag/v2.1.5
- https://github.com/pion/dtls/security/advisories/GHSA-w45j-f832-hxvh
- https://github.com/pion/dtls/commit/d2f797183a9f044ce976e6df6f362662ca722412
- https://github.com/pion/dtls/releases/tag/v2.1.5
- https://github.com/pion/dtls/security/advisories/GHSA-w45j-f832-hxvh
Get alerted when CVE-2022-29222 or the next vulnerability affects your stack