What’s Vulnerable › Vulnerabilities
CVE-2022-29225: Zip bomb vulnerability in Envoy
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-09 · updated 2026-06-17
- Weakness: CWE-400
Description
Envoy is a cloud-native high-performance proxy. In versions prior to 1.22.1 secompressors accumulate decompressed data into an intermediate buffer before overwriting the body in the decode/encodeBody. This may allow an attacker to zip bomb the decompressor by sending a small highly compressed payload. Maliciously constructed zip files may exhaust system memory and cause a denial of service. Users are advised to upgrade. Users unable to upgrade may consider disabling decompression.
Affected products
- envoyproxy envoy: before 1.22.1 — fixed in 1.22.1
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.22.1. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/commit/cb4ef0b09200c720dfdb07e097092dd105450343
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-75hv-2jjj-89hh
- https://github.com/envoyproxy/envoy/commit/cb4ef0b09200c720dfdb07e097092dd105450343
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-75hv-2jjj-89hh
Get alerted when CVE-2022-29225 or the next vulnerability affects your stack