What’s Vulnerable › Vulnerabilities
CVE-2022-29228: Reachable assertion in Envoy
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-09 · updated 2026-06-17
- Weakness: CWE-617
Description
Envoy is a cloud-native high-performance proxy. In versions prior to 1.22.1 the OAuth filter would try to invoke the remaining filters in the chain after emitting a local response, which triggers an ASSERT() in newer versions and corrupts memory on earlier versions. continueDecoding() shouldn’t ever be called from filters after a local reply has been sent. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- envoyproxy envoy: before 1.22.1 — fixed in 1.22.1
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.22.1. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/commit/7ffda4e809dec74449ebc330cebb9d2f4ab61360
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-rww6-8h7g-8jf6
- https://github.com/envoyproxy/envoy/commit/7ffda4e809dec74449ebc330cebb9d2f4ab61360
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-rww6-8h7g-8jf6
Get alerted when CVE-2022-29228 or the next vulnerability affects your stack