What’s Vulnerable › Vulnerabilities
CVE-2022-29230: Potential cross-site scripting (XSS) vulnerability in Hydrogen
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Hydrogen is a React-based framework for building dynamic, Shopify-powered custom storefronts. There is a potential Cross-Site Scripting (XSS) vulnerability where an arbitrary user is able to execute scripts on pages that are built with Hydrogen. This affects all versions of Hydrogen starting from version 0.10.0 to 0.18.0. This vulnerability is exploitable in applications whose hydrating data is user controlled. All Hydrogen users should upgrade their project to version 0.19.0. There is no current workaround, and users should update as soon as possible. Additionally, the Content Security Policy is not an effective mitigation for this vulnerability.
Affected products
- Shopify hydrogen: from 0.10.0 before 0.19.0 — fixed in 0.19.0
How to fix
Upgrade to a fixed version: Shopify hydrogen 0.19.0. Check the vendor advisory for mitigations.
References
- https://github.com/Shopify/hydrogen/pull/1272
- https://github.com/Shopify/hydrogen/releases/tag/%40shopify/hydrogen%400.19.0
- https://github.com/Shopify/hydrogen/security/advisories/GHSA-6j22-wv8g-894f
- https://github.com/Shopify/hydrogen/pull/1272
- https://github.com/Shopify/hydrogen/releases/tag/%40shopify/hydrogen%400.19.0
- https://github.com/Shopify/hydrogen/security/advisories/GHSA-6j22-wv8g-894f
Get alerted when CVE-2022-29230 or the next vulnerability affects your stack