What’s Vulnerable › Vulnerabilities
CVE-2022-29252: Cross-site Scripting in XWiki Platform Wiki UI Main Wiki
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-25 · updated 2026-06-17
- Weakness: CWE-80
Description
XWiki Platform Wiki UI Main Wiki is a package for managing subwikis. Starting with version 5.3-milestone-2, XWiki Platform Wiki UI Main Wiki contains a possible cross-site scripting vector in the `WikiManager.JoinWiki ` wiki page related to the "requestJoin" field. The issue is patched in versions 12.10.11, 14.0-rc-1, 13.4.7, and 13.10.3. The easiest available workaround is to edit the wiki page `WikiManager.JoinWiki` (with wiki editor) according to the suggestion provided in the GitHub Security Advisory.
Affected products
- xwiki-platform: from 5.4 before 12.10.11; from 13.0 before 13.4.7; from 13.5 before 13.10.3; 5.3-milestone2 — fixed in 12.10.11, 13.10.3, 13.4.7
How to fix
Upgrade to a fixed version: xwiki-platform 12.10.11, 13.10.3, 13.4.7. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/27f839133d41877e538d35fa88274b50a1c00b9b
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-ph5x-h23x-7q5q
- https://jira.xwiki.org/browse/XWIKI-19292
- https://github.com/xwiki/xwiki-platform/commit/27f839133d41877e538d35fa88274b50a1c00b9b
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-ph5x-h23x-7q5q
- https://jira.xwiki.org/browse/XWIKI-19292
Get alerted when CVE-2022-29252 or the next vulnerability affects your stack