What’s Vulnerable › Vulnerabilities
CVE-2022-29256: Possible vulnerability at 'npm install' time in sharp if an attacker has control over build environment
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-25 · updated 2026-06-17
- Weakness: CWE-77
Description
sharp is an application for Node.js image processing. Prior to version 0.30.5, there is a possible vulnerability in logic that is run only at `npm install` time when installing versions of `sharp` prior to the latest v0.30.5. If an attacker has the ability to set the value of the `PKG_CONFIG_PATH` environment variable in a build environment then they might be able to use this to inject an arbitrary command at `npm install` time. This is not part of any runtime code, does not affect Windows users at all, and is unlikely to affect anyone that already cares about the security of their build environment. This problem is fixed in version 0.30.5.
Affected products
- lovell sharp: before 0.30.5 — fixed in 0.30.5
How to fix
Upgrade to a fixed version: lovell sharp 0.30.5. Check the vendor advisory for mitigations.
References
- https://github.com/lovell/sharp/commit/a6aeef612be50f5868a77481848b1de674216f0c
- https://github.com/lovell/sharp/security/advisories/GHSA-gp95-ppv5-3jc5
- https://github.com/lovell/sharp/commit/a6aeef612be50f5868a77481848b1de674216f0c
- https://github.com/lovell/sharp/security/advisories/GHSA-gp95-ppv5-3jc5
Get alerted when CVE-2022-29256 or the next vulnerability affects your stack