What’s Vulnerable › Vulnerabilities
CVE-2022-29257: Electron's AutoUpdater module fails to validate certain nested components of the bundle
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-13 · updated 2026-06-17
- Weakness: CWE-20
Description
Electron is a framework for writing cross-platform desktop applications using JavaScript (JS), HTML, and CSS. A vulnerability in versions prior to 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 allows attackers who have control over a given apps update server / update storage to serve maliciously crafted update packages that pass the code signing validation check but contain malicious code in some components. This kind of attack would require significant privileges in a potential victim's own auto updating infrastructure and the ease of that attack entirely depends on the potential victim's infrastructure security. Electron versions 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 contain a fix for this issue. There are no known workarounds.
Affected products
- electron: before 15.5.0; from 16.0.1 before 16.2.0; from 17.0.1 before 17.2.0; 16.0.0-beta1, 16.0.0-beta2, 16.0.0-beta3, 16.0.0-beta4, 16.0.0-beta5, 16.0.0-beta6 (+17) — fixed in 15.5.0, 16.2.0, 17.2.0
How to fix
Upgrade to a fixed version: electron 15.5.0, 16.2.0, 17.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/electron/electron/security/advisories/GHSA-77xc-hjv8-ww97
- https://github.com/electron/electron/security/advisories/GHSA-77xc-hjv8-ww97
Get alerted when CVE-2022-29257 or the next vulnerability affects your stack