What’s Vulnerable › Vulnerabilities
CVE-2022-29266: apisix/jwt-auth may leak secrets in error response
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-20 · updated 2026-06-17
- Weakness: CWE-209
Description
In APache APISIX before 3.13.1, the jwt-auth plugin has a security issue that leaks the user's secret key because the error message returned from the dependency lua-resty-jwt contains sensitive information.
Affected products
- Apache Software Foundation Apache APISIX: before 2.13.1 — fixed in 2.13.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache APISIX 2.13.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/04/20/1
- https://lists.apache.org/thread/6qpfyxogbvn18g9xr8g218jjfjbfsbhr
- http://www.openwall.com/lists/oss-security/2022/04/20/1
- https://lists.apache.org/thread/6qpfyxogbvn18g9xr8g218jjfjbfsbhr
Get alerted when CVE-2022-29266 or the next vulnerability affects your stack