What’s Vulnerable › Vulnerabilities
CVE-2022-29276
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-15 · updated 2026-06-17
- Weakness: CWE-787
Description
SMI functions in AhciBusDxe use untrusted inputs leading to corruption of SMRAM. SMI functions in AhciBusDxe use untrusted inputs leading to corruption of SMRAM. This issue was discovered by Insyde during security review. It was fixed in: Kernel 5.0: version 05.09.18 Kernel 5.1: version 05.17.18 Kernel 5.2: version 05.27.18 Kernel 5.3: version 05.36.18 Kernel 5.4: version 05.44.18 Kernel 5.5: version 05.52.18 https://www.insyde.com/security-pledge/SA-2022059
Affected products
- Insyde Kernel: from 5.0 before 5.0.05.09.18; from 5.1 before 5.1.05.17.18; from 5.2 before 5.2.05.27.18; from 5.3 before 5.3.05.36.18; from 5.4 before 5.4.05.44.18; from 5.5 before 5.5.05.52.18 — fixed in 5.0.05.09.18, 5.1.05.17.18, 5.2.05.27.18, 5.3.05.36.18, 5.4.05.44.18, 5.5.05.52.18
How to fix
Upgrade to a fixed version: Insyde Kernel 5.0.05.09.18, 5.1.05.17.18, 5.2.05.27.18, 5.3.05.36.18. Check the vendor advisory for mitigations.
References
- https://www.insyde.com/security-pledge
- https://www.insyde.com/security-pledge/SA-2022059
- https://www.insyde.com/security-pledge
- https://www.insyde.com/security-pledge/SA-2022059
Get alerted when CVE-2022-29276 or the next vulnerability affects your stack