What’s Vulnerable › Vulnerabilities
CVE-2022-29281
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-15 · updated 2026-06-17
- Weakness: CWE-22
Description
Notable before 1.9.0-beta.8 doesn't effectively prevent the opening of executable files when clicking on a link. There is improper validation of the file URI scheme. A hyperlink to an SMB share could lead to execution of an arbitrary program (or theft of NTLM credentials via an SMB relay attack, because the application resolves UNC paths).
Affected products
- Notable: before 1.9.0; 1.9.0-beta0, 1.9.0-beta1, 1.9.0-beta2, 1.9.0-beta3, 1.9.0-beta4, 1.9.0-beta5 (+2) — fixed in 1.9.0
How to fix
Upgrade to a fixed version: Notable 1.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/hmnthabit/Advisories/blob/master/CVE-2022-29281.md
- https://github.com/notable/notable-insiders/releases/tag/v1.9.0-beta.8
- https://github.com/hmnthabit/Advisories/blob/master/CVE-2022-29281.md
- https://github.com/notable/notable-insiders/releases/tag/v1.9.0-beta.8
Get alerted when CVE-2022-29281 or the next vulnerability affects your stack