What’s Vulnerable › Vulnerabilities
CVE-2022-2929: DHCP memory leak
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-07 · updated 2026-06-17
- Weakness: CWE-770
Description
In ISC DHCP 1.0 -> 4.4.3, ISC DHCP 4.1-ESV-R1 -> 4.1-ESV-R16-P1 a system with access to a DHCP server, sending DHCP packets crafted to include fqdn labels longer than 63 bytes, could eventually cause the server to run out of memory.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 35, 36, 37
- ISC DHCP: from 1.0.0 before 4.1-esv; from 4.2.0 through 4.4.3; 4.1-esv-r1, 4.1-esv-r10, 4.1-esv-r10_b1, 4.1-esv-r10_rc1, 4.1-esv-r10b1, 4.1-esv-r10rc1 (+23) — fixed in 4.1-esv
How to fix
Upgrade to a fixed version: ISC DHCP 4.1-esv. Check the vendor advisory for mitigations.
References
- https://kb.isc.org/docs/cve-2022-2929
- https://lists.debian.org/debian-lts-announce/2022/10/msg00015.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2SARIK7KZ7MGQIWDRWZFAOSQSPXY4GOU/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QQXYCIWUDILRCNBAIMVFCSGXBRKEPB4K/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/T6IBFH4MRRNJQVWEKILQ6I6CXWW766FX/
- https://security.gentoo.org/glsa/202305-22
- https://kb.isc.org/docs/cve-2022-2929
- https://lists.debian.org/debian-lts-announce/2022/10/msg00015.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2SARIK7KZ7MGQIWDRWZFAOSQSPXY4GOU/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QQXYCIWUDILRCNBAIMVFCSGXBRKEPB4K/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/T6IBFH4MRRNJQVWEKILQ6I6CXWW766FX/
- https://security.gentoo.org/glsa/202305-22
Get alerted when CVE-2022-2929 or the next vulnerability affects your stack