What’s Vulnerable › Vulnerabilities
CVE-2022-29416: WordPress Afterpay Gateway for WooCommerce Plugin <= 3.5.0 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Afterpay Gateway for WooCommerce <= 3.5.0 versions.
Affected products
- Afterpay Gateway for WooCommerce: before 3.5.1 — fixed in 3.5.1
How to fix
Upgrade to a fixed version: Afterpay Gateway for WooCommerce 3.5.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/afterpay-gateway-for-woocommerce/wordpress-afterpay-gateway-for-woocommerce-plugin-3-5-0-unauth-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/afterpay-gateway-for-woocommerce/wordpress-afterpay-gateway-for-woocommerce-plugin-3-5-0-unauth-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2022-29416 or the next vulnerability affects your stack