What’s Vulnerable › Vulnerabilities
CVE-2022-2943: WordPress Infinite Scroll – Ajax Load More <= 5.5.3 - Authenticated (Admin+) Arbitrary File Read
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-06 · updated 2026-06-17
- Weakness: CWE-22
Description
The WordPress Infinite Scroll – Ajax Load More plugin for Wordpress is vulnerable to arbitrary file reading in versions up to, and including, 5.5.3 due to insufficient file path validation on the alm_repeaters_export() function. This makes it possible for authenticated attackers, with administrative privileges, to download arbitrary files hosted on the server that may contain sensitive content, such as the wp-config.php file.
Affected products
- dcooney Ajax Load More – Infinite Scroll, Load More, & Lazy Load: before 5.5.4 — fixed in 5.5.4
How to fix
Upgrade to a fixed version: dcooney Ajax Load More – Infinite Scroll, Load More, & Lazy Load 5.5.4. Check the vendor advisory for mitigations.
References
- https://gist.github.com/Xib3rR4dAr/f9a4b4838154854ec6cde7d5deb76bf9
- https://plugins.svn.wordpress.org/ajax-load-more/tags/5.5.4/README.txt
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6d643d07-7533-430b-a1d8-8e66a2a2c5e6?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2943
- https://gist.github.com/Xib3rR4dAr/f9a4b4838154854ec6cde7d5deb76bf9
- https://plugins.svn.wordpress.org/ajax-load-more/tags/5.5.4/README.txt
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6d643d07-7533-430b-a1d8-8e66a2a2c5e6?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2943
Get alerted when CVE-2022-2943 or the next vulnerability affects your stack