What’s Vulnerable › Vulnerabilities
CVE-2022-29454: WordPress Better Messages plugin <= 1.9.9.148 - Cross-Site Request Forgery (CSRF) vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-20 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in WordPlus Better Messages plugin <= 1.9.9.148 at WordPress allows attackers to upload files. File attachment to messages must be activated.
Affected products
- wordplus Better Messages – Live Chat, Chat Rooms, Real-Time Messaging & Private Messages: before 1.9.9.149 — fixed in 1.9.9.149
How to fix
Upgrade to a fixed version: wordplus Better Messages – Live Chat, Chat Rooms, Real-Time Messaging & Private Messages 1.9.9.149. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/bp-better-messages/wordpress-better-messages-plugin-1-9-9-148-cross-site-request-forgery-csrf-vulnerability
- https://wordpress.org/plugins/bp-better-messages/#developers
- https://patchstack.com/database/vulnerability/bp-better-messages/wordpress-better-messages-plugin-1-9-9-148-cross-site-request-forgery-csrf-vulnerability
- https://wordpress.org/plugins/bp-better-messages/#developers
Get alerted when CVE-2022-29454 or the next vulnerability affects your stack