What’s Vulnerable › Vulnerabilities
CVE-2022-2946: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-23 · updated 2026-10-09
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 9.0.0246.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 35
- vim/vim: before 9.0.0246 — fixed in 9.0.0246
How to fix
Upgrade to a fixed version: vim/vim 9.0.0246. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/adce965162dd89bf29ee0e5baf53652e7515762c
- https://huntr.dev/bounties/5d389a18-5026-47df-a5d0-1548a9b555d5
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C72HDIMR3KTTAO7QGTXWUMPBNFUFIBRD/
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/adce965162dd89bf29ee0e5baf53652e7515762c
- https://huntr.dev/bounties/5d389a18-5026-47df-a5d0-1548a9b555d5
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C72HDIMR3KTTAO7QGTXWUMPBNFUFIBRD/
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2946 or the next vulnerability affects your stack