What’s Vulnerable › Vulnerabilities
CVE-2022-29485
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting vulnerability in SHIRASAGI v1.0.0 to v1.14.2, and v1.15.0 allows a remote attacker to inject an arbitrary script via unspecified vectors.
Affected products
- SHIRASAGI Project SHIRASAGI: from 1.0.0 before 1.14.3; 1.15.0 — fixed in 1.14.3
How to fix
Upgrade to a fixed version: SHIRASAGI Project SHIRASAGI 1.14.3. Check the vendor advisory for mitigations.
References
- https://github.com/shirasagi/shirasagi
- https://jvn.jp/en/jp/JVN32962443/index.html
- https://www.ss-proj.org/
- https://www.ss-proj.org/support/843.html
- https://github.com/shirasagi/shirasagi
- https://jvn.jp/en/jp/JVN32962443/index.html
- https://www.ss-proj.org/
- https://www.ss-proj.org/support/843.html
Get alerted when CVE-2022-29485 or the next vulnerability affects your stack