What’s Vulnerable › Vulnerabilities
CVE-2022-29488: Horner Automation Cscape Csfont
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-02 · updated 2026-06-17
- Weakness: CWE-125
Description
The affected product is vulnerable to an out-of-bounds read via uninitialized pointer, which may allow an attacker to execute arbitrary code.
Affected products
- Horner Automation Cscape: before 9.90; 9.90, 9.90-sp1, 9.90-sp2, 9.90-sp3, 9.90-sp4, 9.90-sp5 — fixed in 9.90
How to fix
Upgrade to a fixed version: Horner Automation Cscape 9.90. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-146-02
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-146-02
Get alerted when CVE-2022-29488 or the next vulnerability affects your stack