What’s Vulnerable › Vulnerabilities
CVE-2022-29522
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-14 · updated 2026-06-17
- Weakness: CWE-416
Description
Use after free vulnerability exists in the simulator module contained in the graphic editor 'V-SFT' versions prior to v6.1.6.0, which may allow an attacker to obtain information and/or execute arbitrary code by having a user to open a specially crafted image file.
Affected products
- Fuji Electric V-Server Lite: before 4.0.12.0; before 4.0.13.0a — fixed in 4.0.12.0, 4.0.13.0a
- FUJI ELECTRIC CO., LTD. and Hakko Electronics Co., Ltd. V-SFT: before 6.1.6.0 — fixed in 6.1.6.0
How to fix
Upgrade to a fixed version: Fuji Electric V-Server Lite 4.0.12.0, 4.0.13.0a; FUJI ELECTRIC CO., LTD. and Hakko Electronics Co., Ltd. V-SFT 6.1.6.0. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/vu/JVNVU99188133/index.html
- https://monitouch.fujielectric.com/site/download-e/09vsft6_inf/Search.php
- https://jvn.jp/en/vu/JVNVU99188133/index.html
- https://monitouch.fujielectric.com/site/download-e/09vsft6_inf/Search.php
Get alerted when CVE-2022-29522 or the next vulnerability affects your stack