What’s Vulnerable › Vulnerabilities
CVE-2022-29527
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-20 · updated 2026-06-17
- Weakness: CWE-362
Description
Amazon AWS amazon-ssm-agent before 3.1.1208.0 creates a world-writable sudoers file, which allows local attackers to inject Sudo rules and escalate privileges to root. This occurs in certain situations involving a race condition.
Affected products
- AWS Amazon SSM Agent: before 3.1.1208.0 — fixed in 3.1.1208.0
How to fix
Upgrade to a fixed version: AWS Amazon SSM Agent 3.1.1208.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=1196556
- https://github.com/aws/amazon-ssm-agent/commit/0fe8ae99b2ff25649c7b86d3bc05fc037400aca7
- https://github.com/aws/amazon-ssm-agent/releases/tag/3.1.1208.0
- https://bugzilla.suse.com/show_bug.cgi?id=1196556
- https://github.com/aws/amazon-ssm-agent/commit/0fe8ae99b2ff25649c7b86d3bc05fc037400aca7
- https://github.com/aws/amazon-ssm-agent/releases/tag/3.1.1208.0
Get alerted when CVE-2022-29527 or the next vulnerability affects your stack