What’s Vulnerable › Vulnerabilities
CVE-2022-29530
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-20 · updated 2026-06-22
- Weakness: CWE-79
Description
An issue was discovered in MISP before 2.4.158. There is stored XSS in the galaxy clusters.
Affected products
- MISP: before 2.4.158 — fixed in 2.4.158
How to fix
Upgrade to a fixed version: MISP 2.4.158. Check the vendor advisory for mitigations.
References
- https://github.com/MISP/MISP/commit/107e271d78c255d658ce998285fe6f6c4f291b41
- https://github.com/MISP/MISP/compare/v2.4.157...v2.4.158
- https://zigrin.com/advisories/misp-stored-xss-in-the-galaxy-clusters/
- https://zigrin.com/cakephp-application-cybersecurity-research-protect-your-website-from-stored-xss-attacks-understanding-and-preventing-vulnerabilities-in-open-source-applications/
- https://github.com/MISP/MISP/commit/107e271d78c255d658ce998285fe6f6c4f291b41
- https://github.com/MISP/MISP/compare/v2.4.157...v2.4.158
- https://zigrin.com/advisories/misp-stored-xss-in-the-galaxy-clusters/
- https://zigrin.com/cakephp-application-cybersecurity-research-protect-your-website-from-stored-xss-attacks-understanding-and-preventing-vulnerabilities-in-open-source-applications/
Get alerted when CVE-2022-29530 or the next vulnerability affects your stack