What’s Vulnerable › Vulnerabilities
CVE-2022-29534
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-20 · updated 2026-06-22
- Weakness: CWE-287
Description
An issue was discovered in MISP before 2.4.158. In UsersController.php, password confirmation can be bypassed via vectors involving an "Accept: application/json" header.
Affected products
- MISP: before 2.4.158 — fixed in 2.4.158
How to fix
Upgrade to a fixed version: MISP 2.4.158. Check the vendor advisory for mitigations.
References
- https://github.com/MISP/MISP/commit/01120163a6b4d905029d416e7305575df31df8af
- https://github.com/MISP/MISP/compare/v2.4.157...v2.4.158
- https://zigrin.com/advisories/misp-password-confirmation-can-be-bypassed/
- https://zigrin.com/cakephp-application-cybersecurity-research-the-impact-of-a-php-vulnerability-exploring-the-password-confirmation-bypass-in-misp/
- https://github.com/MISP/MISP/commit/01120163a6b4d905029d416e7305575df31df8af
- https://github.com/MISP/MISP/compare/v2.4.157...v2.4.158
- https://zigrin.com/advisories/misp-password-confirmation-can-be-bypassed/
- https://zigrin.com/cakephp-application-cybersecurity-research-the-impact-of-a-php-vulnerability-exploring-the-password-confirmation-bypass-in-misp/
Get alerted when CVE-2022-29534 or the next vulnerability affects your stack