What’s Vulnerable › Vulnerabilities
CVE-2022-29536
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-20 · updated 2026-06-17
- Weakness: CWE-787
Description
In GNOME Epiphany before 41.4 and 42.x before 42.2, an HTML document can trigger a client buffer overflow (in ephy_string_shorten in the UI process) via a long page title. The issue occurs because the number of bytes for a UTF-8 ellipsis character is not properly considered.
Affected products
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 34, 35, 36
- GNOME Epiphany: before 41.4; from 42.0 before 42.2 — fixed in 41.4, 42.2
How to fix
Upgrade to a fixed version: GNOME Epiphany 41.4, 42.2. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/epiphany/-/merge_requests/1106
- https://lists.debian.org/debian-lts-announce/2022/08/msg00006.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GLLDMY4JYDZTMZSCPSY23K5YW3SQYUR6/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/N7YWVIUGFRA6GOE3QAPSJJ6EL3DJG5NX/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U5K5UPNHVWXDPSMBNSB2645MD2N5CXQS/
- https://www.debian.org/security/2022/dsa-5208
- https://gitlab.gnome.org/GNOME/epiphany/-/merge_requests/1106
- https://lists.debian.org/debian-lts-announce/2022/08/msg00006.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GLLDMY4JYDZTMZSCPSY23K5YW3SQYUR6/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/N7YWVIUGFRA6GOE3QAPSJJ6EL3DJG5NX/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U5K5UPNHVWXDPSMBNSB2645MD2N5CXQS/
- https://www.debian.org/security/2022/dsa-5208
Get alerted when CVE-2022-29536 or the next vulnerability affects your stack