What’s Vulnerable › Vulnerabilities
CVE-2022-29546
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-25 · updated 2026-06-17
Description
HtmlUnit NekoHtml Parser before 2.61.0 suffers from a denial of service vulnerability. Crafted input associated with the parsing of Processing Instruction (PI) data leads to heap memory consumption. This is similar to CVE-2022-28366 but affects a much later version of the product.
Affected products
- net.sourceforge.htmlunit:htmlunit: before 2.61.0 — fixed in 2.61.0
How to fix
Upgrade to a fixed version: net.sourceforge.htmlunit:htmlunit 2.61.0. Check the vendor advisory for mitigations.
References
- https://github.com/HtmlUnit/htmlunit-neko/security/advisories/GHSA-6jmm-mp6w-4rrg
- https://github.com/HtmlUnit/htmlunit-neko/security/advisories/GHSA-6jmm-mp6w-4rrg
Get alerted when CVE-2022-29546 or the next vulnerability affects your stack