What’s Vulnerable › Vulnerabilities
CVE-2022-2958: BadgeOS < 3.7.1.3 - Subscriber+ SQLi
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-19 · updated 2026-06-17
- Weakness: CWE-89
Description
The BadgeOS WordPress plugin before 3.7.1.3 does not sanitise and escape parameters before using them in SQL statements via AJAX actions available to any authenticated users, leading to SQL Injections
Affected products
- Badgeos Badgos: before 3.7.1.3 — fixed in 3.7.1.3
How to fix
Upgrade to a fixed version: Badgeos Badgos 3.7.1.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8743534f-8ebd-496a-99bc-5052a8bac86a
- https://wpscan.com/vulnerability/8743534f-8ebd-496a-99bc-5052a8bac86a
Get alerted when CVE-2022-2958 or the next vulnerability affects your stack