What’s Vulnerable › Vulnerabilities
CVE-2022-29599: Commandline class shell injection vulnerabilities
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-23 · updated 2026-06-17
- Weakness: CWE-116
Description
In Apache Maven maven-shared-utils prior to version 3.3.3, the Commandline class can emit double-quoted strings without proper escaping, allowing shell injection attacks.
Affected products
- Apache Maven Shared Utils: before 3.3.3 — fixed in 3.3.3
- Debian Linux: 10.0, 11.0
How to fix
Upgrade to a fixed version: Apache Maven Shared Utils 3.3.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/05/23/3
- https://github.com/apache/maven-shared-utils/pull/40
- https://issues.apache.org/jira/browse/MSHARED-297
- https://lists.debian.org/debian-lts-announce/2022/08/msg00018.html
- https://www.debian.org/security/2022/dsa-5242
- http://www.openwall.com/lists/oss-security/2022/05/23/3
- https://github.com/apache/maven-shared-utils/pull/40
- https://issues.apache.org/jira/browse/MSHARED-297
- https://lists.debian.org/debian-lts-announce/2022/08/msg00018.html
- https://www.debian.org/security/2022/dsa-5242
Get alerted when CVE-2022-29599 or the next vulnerability affects your stack