What’s Vulnerable › Vulnerabilities
CVE-2022-29602
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The gridelements (aka Grid Elements) extension through 7.6.1, 8.x through 8.7.0, 9.x through 9.7.0, and 10.x through 10.2.0 extension for TYPO3 allows XSS.
Affected products
- Grid Elements Project Grid Elements: before 7.7.0; from 8.0.0 before 8.8.0; from 9.0.0 before 9.8.0; from 10.0.0 before 10.3.0 — fixed in 10.3.0, 7.7.0, 8.8.0, 9.8.0
How to fix
Upgrade to a fixed version: Grid Elements Project Grid Elements 10.3.0, 7.7.0, 8.8.0, 9.8.0. Check the vendor advisory for mitigations.
References
- https://typo3.org/help/security-advisories
- https://typo3.org/security/advisory/typo3-ext-sa-2022-009
- https://typo3.org/help/security-advisories
- https://typo3.org/security/advisory/typo3-ext-sa-2022-009
Get alerted when CVE-2022-29602 or the next vulnerability affects your stack