What’s Vulnerable › Vulnerabilities
CVE-2022-29631
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-06 · updated 2026-06-17
- Weakness: CWE-74
Description
Jodd HTTP v6.0.9 was discovered to contain multiple CLRF injection vulnerabilities via the components jodd.http.HttpRequest#set and `jodd.http.HttpRequest#send. These vulnerabilities allow attackers to execute Server-Side Request Forgery (SSRF) via a crafted TCP payload.
Affected products
- Jodd Http: from 5.0 before 6.2.1 — fixed in 6.2.1
How to fix
Upgrade to a fixed version: Jodd Http 6.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/oblac/jodd-http/issues/9
- https://github.com/oblac/jodd/issues/787
- https://github.com/oblac/jodd-http/issues/9
- https://github.com/oblac/jodd/issues/787
Get alerted when CVE-2022-29631 or the next vulnerability affects your stack