What’s Vulnerable › Vulnerabilities
CVE-2022-2964
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-09 · updated 2026-06-17
- Weakness: CWE-119
Description
A flaw was found in the Linux kernel’s driver for the ASIX AX88179_178A-based USB 2.0/3.0 Gigabit Ethernet Devices. The vulnerability contains multiple out-of-bounds reads and possible out-of-bounds writes.
Affected products
- Linux kernel: from 4.20 before 5.4.180; from 5.5 before 5.10.101; from 5.11 before 5.15.24; from 5.16 before 5.16.10 — fixed in 5.10.101, 5.15.24, 5.16.10, 5.4.180
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700S Firmware: all versions
- Red Hat Enterprise Linux: 7.0, 8.0, 9.0
How to fix
Upgrade to a fixed version: Linux kernel 5.10.101, 5.15.24, 5.16.10, 5.4.180. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2067482
- https://security.netapp.com/advisory/ntap-20230113-0001/
- https://bugzilla.redhat.com/show_bug.cgi?id=2067482
- https://security.netapp.com/advisory/ntap-20230113-0001/
Get alerted when CVE-2022-2964 or the next vulnerability affects your stack