What’s Vulnerable › Vulnerabilities
CVE-2022-29654
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-22 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer overflow vulnerability in quote_for_pmake in asm/nasm.c in nasm before 2.15.05 allows attackers to cause a denial of service via crafted file.
Affected products
- NASM Netwide Assember: before 2.15.05 — fixed in 2.15.05
How to fix
Upgrade to a fixed version: NASM Netwide Assember 2.15.05. Check the vendor advisory for mitigations.
References
- https://gcc.gnu.org/onlinedocs/gcc/Instrumentation-Options.html
- https://gist.github.com/naihsin/b96e2c5c2c81621b46557fd7aacd165f
- https://www.nasm.us/pub/nasm/releasebuilds/2.15.05/
- https://gcc.gnu.org/onlinedocs/gcc/Instrumentation-Options.html
- https://gist.github.com/naihsin/b96e2c5c2c81621b46557fd7aacd165f
- https://www.nasm.us/pub/nasm/releasebuilds/2.15.05/
Get alerted when CVE-2022-29654 or the next vulnerability affects your stack