What’s Vulnerable › Vulnerabilities
CVE-2022-29695
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-02 · updated 2026-06-17
- Weakness: CWE-665
Description
Unicorn Engine v2.0.0-rc7 contains memory leaks caused by an incomplete unicorn engine initialization.
Affected products
- Unicorn-Engine Unicorn Engine: before 2.0.0; 2.0.0, 2.0.0-rc1, 2.0.0-rc2, 2.0.0-rc3, 2.0.0-rc4, 2.0.0-rc5 (+1) — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Unicorn-Engine Unicorn Engine 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/unicorn-engine/unicorn/commit/5a79d7879ca3ee0ce684ad6576d8ac15e8d90fc7
- https://github.com/unicorn-engine/unicorn/issues/1595
- https://github.com/unicorn-engine/unicorn/commit/5a79d7879ca3ee0ce684ad6576d8ac15e8d90fc7
- https://github.com/unicorn-engine/unicorn/issues/1595
Get alerted when CVE-2022-29695 or the next vulnerability affects your stack