What’s Vulnerable › Vulnerabilities
CVE-2022-29718
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-02 · updated 2026-06-17
- Weakness: CWE-601
Description
Caddy v2.4 was discovered to contain an open redirect vulnerability. A remote unauthenticated attacker may exploit this vulnerability to redirect users to arbitrary web URLs by tricking the victim users to click on crafted links.
Affected products
- caddyserver caddy: from 2.4.0 before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: caddyserver caddy 2.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/caddyserver/caddy/pull/4499
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CP2VIUT5IKA3OKM6YWA5LTLJ2GTEIH7C/
- https://github.com/caddyserver/caddy/pull/4499
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CP2VIUT5IKA3OKM6YWA5LTLJ2GTEIH7C/
Get alerted when CVE-2022-29718 or the next vulnerability affects your stack