What’s Vulnerable › Vulnerabilities
CVE-2022-2977
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-14 · updated 2026-06-17
- Weakness: CWE-416
Description
A flaw was found in the Linux kernel implementation of proxied virtualized TPM devices. On a system where virtualized TPM devices are configured (this is not the default) a local attacker can create a use-after-free and create a situation where it may be possible to escalate privileges on the system.
Affected products
- Linux kernel: from 4.12 before 4.14.276; from 4.15 before 4.19.238; from 4.20 before 5.4.189; from 5.5 before 5.10.110; from 5.11 before 5.15.33; from 5.16 before 5.16.19 — fixed in 4.14.276, 4.19.238, 5.10.110, 5.15.33, 5.16.19, 5.17.1
How to fix
Upgrade to a fixed version: Linux kernel 4.14.276, 4.19.238, 5.10.110, 5.15.33. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=9d8e7007dc7c4d7c8366739bbcd3f5e51dcd470f
- https://security.netapp.com/advisory/ntap-20230214-0006/
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=9d8e7007dc7c4d7c8366739bbcd3f5e51dcd470f
- https://security.netapp.com/advisory/ntap-20230214-0006/
Get alerted when CVE-2022-2977 or the next vulnerability affects your stack