What’s Vulnerable › Vulnerabilities
CVE-2022-29806
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 67.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-26 · updated 2026-06-17
- Weakness: CWE-22
Description
ZoneMinder before 1.36.13 allows remote code execution via an invalid language. Ability to create a debug log file at an arbitrary pathname contributes to exploitability.
Affected products
- zoneminder: before 1.36.13 — fixed in 1.36.13
How to fix
Upgrade to a fixed version: zoneminder 1.36.13. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/166980/ZoneMinder-Language-Settings-Remote-Code-Execution.html
- https://forums.zoneminder.com/viewtopic.php?t=31638
- https://github.com/ZoneMinder/zoneminder/commit/9fee64b62fbdff5bf5ece1d617f1f53c7b1967cb
- https://github.com/ZoneMinder/zoneminder/releases/tag/1.36.13
- https://krastanoel.com/cve/2022-29806
- http://packetstormsecurity.com/files/166980/ZoneMinder-Language-Settings-Remote-Code-Execution.html
- https://forums.zoneminder.com/viewtopic.php?t=31638
- https://github.com/ZoneMinder/zoneminder/commit/9fee64b62fbdff5bf5ece1d617f1f53c7b1967cb
- https://github.com/ZoneMinder/zoneminder/releases/tag/1.36.13
- https://krastanoel.com/cve/2022-29806
Get alerted when CVE-2022-29806 or the next vulnerability affects your stack