What’s Vulnerable › Vulnerabilities
CVE-2022-29814
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-28 · updated 2026-06-17
- Weakness: CWE-94
Description
In JetBrains IntelliJ IDEA before 2022.1 local code execution via HTML descriptions in custom JSON schemas was possible
Affected products
- JetBrains IntelliJ IDEA: before 2022.1 — fixed in 2022.1
How to fix
Upgrade to a fixed version: JetBrains IntelliJ IDEA 2022.1. Check the vendor advisory for mitigations.
References
- https://www.jetbrains.com/privacy-security/issues-fixed/
- https://www.jetbrains.com/privacy-security/issues-fixed/
Get alerted when CVE-2022-29814 or the next vulnerability affects your stack