What’s Vulnerable › Vulnerabilities
CVE-2022-29824
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-03 · updated 2026-10-14
- Weakness: CWE-190
Description
In libxml2 before 2.9.14, several buffer handling functions in buf.c (xmlBuf*) and tree.c (xmlBuffer*) don't check for integer overflows. This can result in out-of-bounds memory writes. Exploitation requires a victim to open a crafted, multi-gigabyte XML file. Other software using libxml2's buffer functions, for example libxslt through 1.1.35, is affected as well.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 34, 35, 36
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- Clustered Data ONTAP: all versions
- NetApp Clustered Data Ontap Antivirus Connector: all versions
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700S Firmware: all versions
- NetApp Manageability Software Development Kit: all versions
- NetApp ONTAP Select Deploy administration utility: all versions
- NetApp Smi-S Provider: all versions
- NetApp Snapdrive: all versions
- SnapManager for Oracle: all versions
- NetApp Solidfire & Hci Management Node: all versions
- Oracle Corporation Oracle ZFS Storage Appliance Kit: 8.8
- xmlsoft libxml2: before 2.9.14 — fixed in 2.9.14
- xmlsoft libxslt: through 1.1.35
How to fix
Upgrade to a fixed version: xmlsoft libxml2 2.9.14. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/167345/libxml2-xmlBufAdd-Heap-Buffer-Overflow.html
- http://packetstormsecurity.com/files/169825/libxml2-xmlParseNameComplex-Integer-Overflow.html
- https://gitlab.gnome.org/GNOME/libxml2/-/commit/2554a2408e09f13652049e5ffb0d26196b02ebab
- https://gitlab.gnome.org/GNOME/libxml2/-/commit/6c283d83eccd940bcde15634ac8c7f100e3caefd
- https://gitlab.gnome.org/GNOME/libxml2/-/tags/v2.9.14
- https://gitlab.gnome.org/GNOME/libxslt/-/tags
- https://lists.debian.org/debian-lts-announce/2022/05/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FZOBT5Y6Y2QLDDX2HZGMV7MJMWGXORKK/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/P3NVZVWFRBXBI3AKZZWUWY6INQQPQVSF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/P5363EDV5VHZ5C77ODA43RYDCPMA7ARM/
- https://security.gentoo.org/glsa/202210-03
- https://security.netapp.com/advisory/ntap-20220715-0006/
Get alerted when CVE-2022-29824 or the next vulnerability affects your stack