What’s Vulnerable › Vulnerabilities
CVE-2022-29849
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-02 · updated 2026-06-17
Description
In Progress OpenEdge before 11.7.14 and 12.x before 12.2.9, certain SUID binaries within the OpenEdge application were susceptible to privilege escalation. If exploited, a local attacker could elevate their privileges and compromise the affected system.
Affected products
- Progress Software Corporation OpenEdge: from 11.7 before 11.7.14; from 12.0.0 before 12.2.9 — fixed in 11.7.14, 12.2.9
How to fix
Upgrade to a fixed version: Progress Software Corporation OpenEdge 11.7.14, 12.2.9. Check the vendor advisory for mitigations.
References
- https://community.progress.com/s/article/OpenEdge-11-7-14-is-Now-Available
- https://community.progress.com/s/article/OpenEdge-12-2-9-Update-is-available
- https://community.progress.com/s/article/Remediation-of-Privilege-Escalation-Security-Vulnerability-CVE-2022-29849
- https://www.progress.com/openedge
- https://community.progress.com/s/article/OpenEdge-11-7-14-is-Now-Available
- https://community.progress.com/s/article/OpenEdge-12-2-9-Update-is-available
- https://community.progress.com/s/article/Remediation-of-Privilege-Escalation-Security-Vulnerability-CVE-2022-29849
- https://www.progress.com/openedge
Get alerted when CVE-2022-29849 or the next vulnerability affects your stack