What’s Vulnerable › Vulnerabilities
CVE-2022-2986
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-06 · updated 2026-06-17
- Weakness: CWE-352
Description
Enabling and disabling installed H5P libraries did not include the necessary token to prevent a CSRF risk.
Affected products
- Moodle: from 3.11.0 before 3.11.9; from 4.0.0 before 4.0.3 — fixed in 3.11.9, 4.0.3
How to fix
Upgrade to a fixed version: Moodle 3.11.9, 4.0.3. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-75326
- https://bugzilla.redhat.com/show_bug.cgi?id=2121360
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-75326
- https://bugzilla.redhat.com/show_bug.cgi?id=2121360
Get alerted when CVE-2022-2986 or the next vulnerability affects your stack