What’s Vulnerable › Vulnerabilities
CVE-2022-29869
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-28 · updated 2026-06-17
- Weakness: CWE-532
Description
cifs-utils through 6.14, with verbose logging, can cause an information leak when a file contains = (equal sign) characters but is not a valid credentials file.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 34, 35, 36
- samba cifs-utils: before 6.15 — fixed in 6.15
How to fix
Upgrade to a fixed version: samba cifs-utils 6.15. Check the vendor advisory for mitigations.
References
- https://github.com/piastry/cifs-utils/commit/8acc963a2e7e9d63fe1f2e7f73f5a03f83d9c379
- https://github.com/piastry/cifs-utils/pull/7
- https://lists.debian.org/debian-lts-announce/2022/05/msg00020.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5WBOLMANBYJILXQKRRK7OCR774PXJAYY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HXKZLJYJJEC3TIBFLXUORRMZUKG5W676/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QIYZ4L6SLSYJQ446VJAO2VGAESURQNSP/
- https://security.gentoo.org/glsa/202311-05
- https://www.debian.org/security/2022/dsa-5157
- https://github.com/piastry/cifs-utils/commit/8acc963a2e7e9d63fe1f2e7f73f5a03f83d9c379
- https://github.com/piastry/cifs-utils/pull/7
- https://lists.debian.org/debian-lts-announce/2022/05/msg00020.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5WBOLMANBYJILXQKRRK7OCR774PXJAYY/
Get alerted when CVE-2022-29869 or the next vulnerability affects your stack