What’s Vulnerable › Vulnerabilities
CVE-2022-2987: Ldap WP Login / Active Directory Integration < 3.0.2 - Unauthenticated Settings Update to Auth Bypass
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-26 · updated 2026-06-17
- Weakness: CWE-352
Description
The Ldap WP Login / Active Directory Integration WordPress plugin before 3.0.2 does not have any authorisation and CSRF checks when updating it's settings (which are hooked to the init action), allowing unauthenticated attackers to update them. Attackers could set their own LDAP server to be used to authenticated users, therefore bypassing the current authentication
Affected products
- Ldap WP Login / Active Directory Integration: before 3.0.2 — fixed in 3.0.2
How to fix
Upgrade to a fixed version: Ldap WP Login / Active Directory Integration 3.0.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0d9638b9-bf8a-474f-992d-2618884d3f67
- https://wpscan.com/vulnerability/0d9638b9-bf8a-474f-992d-2618884d3f67
Get alerted when CVE-2022-2987 or the next vulnerability affects your stack