What’s Vulnerable › Vulnerabilities
CVE-2022-29890
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-15 · updated 2026-06-17
- Weakness: CWE-79
Description
In affected versions of Octopus Server the help sidebar can be customized to include a Cross-Site Scripting payload in the support link.
Affected products
- Octopus Deploy Octopus Server: from 2019.7.0 before 2021.3.13021; from 2022.1.2121 before 2022.1.2849; from 2022.3.348 before 2022.3.2387; 2022.2.6729 — fixed in 2021.3.13021, 2022.1.2849, 2022.3.2387
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2021.3.13021, 2022.1.2849, 2022.3.2387. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-07/
- https://advisories.octopus.com/post/2022/sa2022-07/
Get alerted when CVE-2022-29890 or the next vulnerability affects your stack