What’s Vulnerable › Vulnerabilities
CVE-2022-2990
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-13 · updated 2026-06-17
- Weakness: CWE-842
Description
An incorrect handling of the supplementary groups in the Buildah container engine might lead to the sensitive information disclosure or possible data modification if an attacker has direct access to the affected container where supplementary groups are used to set access permissions and is able to execute a binary code in that container.
Affected products
- Buildah Project Buildah: before 1.27.1 — fixed in 1.27.1
- Red Hat Enterprise Linux: 7.0, 8.0, 9.0
- Red Hat OpenShift Container Platform 4.18: 4.0
How to fix
Upgrade to a fixed version: Buildah Project Buildah 1.27.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2121453
- https://www.benthamsgaze.org/2022/08/22/vulnerability-in-linux-containers-investigation-and-mitigation/
- https://bugzilla.redhat.com/show_bug.cgi?id=2121453
- https://www.benthamsgaze.org/2022/08/22/vulnerability-in-linux-containers-investigation-and-mitigation/
Get alerted when CVE-2022-2990 or the next vulnerability affects your stack