What’s Vulnerable › Vulnerabilities
CVE-2022-29909
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-276
Description
Documents in deeply-nested cross-origin browsing contexts could have obtained permissions granted to the top-level origin, bypassing the existing prompt and wrongfully inheriting the top-level permissions. This vulnerability affects Thunderbird < 91.9, Firefox ESR < 91.9, and Firefox < 100.
Affected products
- Mozilla Firefox: before 100.0 — fixed in 100.0
- Mozilla Firefox ESR: before 91.9 — fixed in 91.9
- Mozilla Thunderbird: before 91.9 — fixed in 91.9
How to fix
Upgrade to a fixed version: Mozilla Firefox 100.0; Mozilla Firefox ESR 91.9; Mozilla Thunderbird 91.9. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1755081
- https://www.mozilla.org/security/advisories/mfsa2022-16/
- https://www.mozilla.org/security/advisories/mfsa2022-17/
- https://www.mozilla.org/security/advisories/mfsa2022-18/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1755081
- https://www.mozilla.org/security/advisories/mfsa2022-16/
- https://www.mozilla.org/security/advisories/mfsa2022-17/
- https://www.mozilla.org/security/advisories/mfsa2022-18/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1755081
Get alerted when CVE-2022-29909 or the next vulnerability affects your stack