What’s Vulnerable › Vulnerabilities
CVE-2022-29911
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-1021
Description
An improper implementation of the new iframe sandbox keyword <code>allow-top-navigation-by-user-activation</code> could lead to script execution without <code>allow-scripts</code> being present. This vulnerability affects Thunderbird < 91.9, Firefox ESR < 91.9, and Firefox < 100.
Affected products
- Mozilla Firefox: before 100.0 — fixed in 100.0
- Mozilla Firefox ESR: before 91.9 — fixed in 91.9
- Mozilla Thunderbird: before 91.9 — fixed in 91.9
How to fix
Upgrade to a fixed version: Mozilla Firefox 100.0; Mozilla Firefox ESR 91.9; Mozilla Thunderbird 91.9. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1761981
- https://www.mozilla.org/security/advisories/mfsa2022-16/
- https://www.mozilla.org/security/advisories/mfsa2022-17/
- https://www.mozilla.org/security/advisories/mfsa2022-18/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1761981
- https://www.mozilla.org/security/advisories/mfsa2022-16/
- https://www.mozilla.org/security/advisories/mfsa2022-17/
- https://www.mozilla.org/security/advisories/mfsa2022-18/
Get alerted when CVE-2022-29911 or the next vulnerability affects your stack