What’s Vulnerable › Vulnerabilities

CVE-2022-2992

Description

A vulnerability in GitLab CE/EE affecting all versions from 11.10 prior to 15.1.6, 15.2 to 15.2.4, 15.3 to 15.3.2 allows an authenticated user to achieve remote code execution via the Import from GitHub API endpoint.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.1.6, 15.2.4, 15.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-2992 or the next vulnerability affects your stack