What’s Vulnerable › Vulnerabilities
CVE-2022-29923: WordPress Quick Restaurant Reservations plugin <= 1.4.1 - Authenticated Reflected Cross-Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) vulnerability in ThingsForRestaurants Quick Restaurant Reservations (WordPress plugin) allows Reflected XSS.This issue affects Quick Restaurant Reservations (WordPress plugin): from n/a through 1.4.1.
Affected products
- ThingsForRestaurants Quick Restaurant Reservations: before 1.4.2 — fixed in 1.4.2
How to fix
Upgrade to a fixed version: ThingsForRestaurants Quick Restaurant Reservations 1.4.2. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/quick-restaurant-reservations/wordpress-quick-restaurant-reservations-plugin-1-4-1-authenticated-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/quick-restaurant-reservations/wordpress-quick-restaurant-reservations-plugin-1-4-1-authenticated-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2022-29923 or the next vulnerability affects your stack