What’s Vulnerable › Vulnerabilities
CVE-2022-29968
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-02 · updated 2026-10-02
- Weakness: CWE-909
Description
An issue was discovered in the Linux kernel through 5.17.5. io_rw_init_file in fs/io_uring.c lacks initialization of kiocb->private.
Affected products
- Fedoraproject Fedora: 34, 35, 36
- Linux kernel: from 5.16 before 5.17.6 — fixed in 5.17.6
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700S Firmware: all versions
- NetApp Solidfire & Hci Management Node: all versions
How to fix
Upgrade to a fixed version: Linux kernel 5.17.6. Check the vendor advisory for mitigations.
References
- https://github.com/torvalds/linux/commit/32452a3eb8b64e01e2be717f518c0be046975b9d
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LU7MT7BPTA2NG24BTLZF5ZWYTLSO7BU3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TLWTG3TWIMLNQEVTA3ZQYVLLU2AJM3DY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XA7UZ3HS73KXVYCIKN5ZDH7LLLGPUMOZ/
- https://security.netapp.com/advisory/ntap-20220715-0009/
- https://github.com/torvalds/linux/commit/32452a3eb8b64e01e2be717f518c0be046975b9d
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LU7MT7BPTA2NG24BTLZF5ZWYTLSO7BU3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TLWTG3TWIMLNQEVTA3ZQYVLLU2AJM3DY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XA7UZ3HS73KXVYCIKN5ZDH7LLLGPUMOZ/
- https://security.netapp.com/advisory/ntap-20220715-0009/
Get alerted when CVE-2022-29968 or the next vulnerability affects your stack