What’s Vulnerable › Vulnerabilities
CVE-2022-29970
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-02 · updated 2026-06-17
- Weakness: CWE-22
Description
Sinatra before 2.2.0 does not validate that the expanded path matches public_dir when serving static files.
Affected products
- Debian Linux: 10.0
- sinatra: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: sinatra 2.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/sinatra/sinatra/pull/1683/commits/462c3ca1db53ed3cfc394cf5948e9c948ad1c10e
- https://lists.debian.org/debian-lts-announce/2022/10/msg00034.html
- https://github.com/sinatra/sinatra/pull/1683/commits/462c3ca1db53ed3cfc394cf5948e9c948ad1c10e
- https://lists.debian.org/debian-lts-announce/2022/10/msg00034.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00020.html
Get alerted when CVE-2022-29970 or the next vulnerability affects your stack