What’s Vulnerable › Vulnerabilities
CVE-2022-30114
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-19 · updated 2026-06-17
- Weakness: CWE-787
Description
A heap-based buffer overflow in a network service in Fastweb FASTGate MediaAccess FGA2130FWB, firmware version 18.3.n.0482_FW_230_FGA2130, and DGA4131FWB, firmware version up to 18.3.n.0462_FW_261_DGA4131, allows a remote attacker to reboot the device through a crafted HTTP request, causing DoS.
Affected products
- Fastweb Fastgate Gpon Fga2130Fwb Firmware: before 18.3.n.0482_fw_233_fga2130 — fixed in 18.3.n.0482_fw_233_fga2130
- Fastweb Fastgate Vdsl2 Dga4131Fwb Firmware: before 18.3.n.0482_fw_264_dga4131 — fixed in 18.3.n.0482_fw_264_dga4131
How to fix
Upgrade to a fixed version: Fastweb Fastgate Gpon Fga2130Fwb Firmware 18.3.n.0482_fw_233_fga2130; Fastweb Fastgate Vdsl2 Dga4131Fwb Firmware 18.3.n.0482_fw_264_dga4131. Check the vendor advisory for mitigations.
References
- https://str0ng4le.github.io/jekyll/update/2023/05/12/fastgate-bof-cve-2022-30114/
- https://www.fastweb.it/myfastweb/assistenza/guide/FASTGate/
- https://str0ng4le.github.io/jekyll/update/2023/05/12/fastgate-bof-cve-2022-30114/
- https://www.fastweb.it/myfastweb/assistenza/guide/FASTGate/
Get alerted when CVE-2022-30114 or the next vulnerability affects your stack