What’s Vulnerable › Vulnerabilities
CVE-2022-30119
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-24 · updated 2026-06-17
- Weakness: CWE-79
Description
XSS in /dashboard/reports/logs/view - old browsers only. When using Internet Explorer with the XSS protection disabled, insufficient sanitation where built urls are outputted can be exploited for Concrete 8.5.7 and below as well as Concrete 9.0 through 9.0.2. This cannot be exploited in modern-day web browsers due to an automatic input escape mechanism. Concrete CMS Security team ranked this vulnerability 2 with CVSS v3.1 Vector AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N. Thanks zeroinside for reporting.
Affected products
- Concrete CMS: before 8.5.8; from 9.0.0 before 9.1.0 — fixed in 8.5.8, 9.1.0
How to fix
Upgrade to a fixed version: Concrete CMS 8.5.8, 9.1.0. Check the vendor advisory for mitigations.
References
- https://documentation.concretecms.org/developers/introduction/version-history/858-release-notes
- https://documentation.concretecms.org/developers/introduction/version-history/910-release-notes
- https://hackerone.com/reports/1370054
- https://documentation.concretecms.org/developers/introduction/version-history/858-release-notes
- https://documentation.concretecms.org/developers/introduction/version-history/910-release-notes
- https://hackerone.com/reports/1370054
Get alerted when CVE-2022-30119 or the next vulnerability affects your stack